Hello and happy Wednesday to all our Definitive Edition adventurers!

Update 28529 is aimed at fixing at some of the more recent pain points you’ve helped identify over the last few weeks: including issues with the multiplayer lobby and match setup, villager pathfindingregion selection, and a handful of other areas. Your feedback has been invaluable in helping us identify the issues preventing you from playing or enjoying the game, so be sure to grab the new build, check out the notes below, play with the changes, and—most importantly—let us know whether they’ve fixed the issues at hand. The best place to do so is on the official forum:


DISCUSS: Age of Empires: Definitive Edition – Update 28529 Discussion


You are also encouraged to come visit us on Discord, where you can organize games, troubleshoot issues, engage with the development team, and interact with other Age of Empires players:


JOIN: The Age of Empires Official Discord


We look forward to hearing what you think of Update 28529, and we’ll see you on the battlefield!

—The Age of Empires Team

 


Update 28529


▪ MS STORE ▪

Remember that you’ll need update your game in the Microsoft Store:

  1. Open the Microsoft Store.
  2. Click the [ ∙ ∙ ∙ ] symbol next to your profile picture.
  3. Select Downloads and updates.
  4. Press the Get updates button to automatically detect, download, and install the latest changes to your game!
  5. Open the game. The title screen should read Build 28529

That’s it; you’re ready to play!

▪ STEAM ▪

Remember that you’ll need update your game in Steam:

  1. Open Steam
  2. Click on Library to see your games list.
  3. Click Downloads at the bottom of the Library window.
  4. [If the new build does not download automatically,] click the button to manually download the new update.
  5. Open the game. The title screen should read Build 28529

That’s it; you’re ready to play!

♦     ♦     ♦

GENERAL

  • The game no longer auto-pauses when switching focus away from the game.
  • Fixed a rare issue that resulted in an ‘Unable to setup storagePoint’ error when launching the game.

 

GAMEPLAY

  • Reduced the collision size of villagers to improve resource collection/pathfinding.
  • Ranked games now require even teams before they can be started.

 

BUG FIXES

  • The multiplayer region now correctly defaults to the detected region of the host.
  • Fixed an issue where the last player to join a ranked lobby was incorrectly muted.
  • Fixed a rare issue where pressing the ESC key would not exit out of the Tech Tree overlay.

 

♦     ♦     ♦

Discuss of 50 comments

  • timotheospetros January 11, 2020

    As can be seen from comments below, AoE fans have been seriously betrayed by Microsoft's failure to explain to them in clear simple terms that version 28529 is an update to the REPLACEMENT EDITION of AoE, not an update to the ORIGINAL EDITION whose final version is 27374. The replacement edition is free to purchasers of the original edition, and both editions can coexist on the same computer.

    So much effort expended in creating a brilliant game, and so little (if any) in ensuring all their customers fully understand how the replacement edition is not an update to the original.

    Reply
  • roysten712 January 11, 2020

    An observation I've made - I have updated the game from the Microsoft Store, which shows the build to be the 28529 version. If I play from the Microsoft store the game launches to the updated 28529 version, if I launch the game from my start menu it is the old 27374.

    Having a closer look I can see that there are now two versions on my start menu. I wonder if this means the game is installed twice...

    Reply
  • dysi1993 January 10, 2020

    I had the problem that the game would not update and stay on version 27374.
    Fix:
    Go to the microsoft store and search for 'xbox (bèta)'. This is the new 'game launcher' i suppose. Download it and open it. Search for AOE and click install. It will notice that it is already on your device and will be done within a minute. Launch the game from the new launcher and it will be the newest version. I hope this helps

    Reply
  • misza January 4, 2020

    Transport boats and hoplites are not showing up after creating. They take resources and population, but they are untargetable. I can see an upgraded transport ship reflecion in water, but no ship and no possibility to target. Hoplites just disappear forever. They also don't react to enemy units.

    Reply
  • numerousbridge1 December 31, 2019

    Hi, I cannot launch the game and there is no updates section on my Microsoft account. Can you please help? Thanks

    Reply
  • numerousbridge1 December 31, 2019
    Reply
  • teeoreece December 8, 2019

    I got the same problem, coulnd see downloads and updates.
    Then i did uninstall the game, new download from mircosoftstore and then new install.
    The game was then already with the update 28529.

    Reply
  • anearther December 2, 2019

    It's been months and I still can't update from MS store, it just won't show up among the "Downloads and updates" section, damn I should have stayed with the cracked version rather than buying the product, there's even a patch for that one already ... silly me.

    Don't dare abandon this artwork to just focus on AoE 2 DE please, they're both such jewels for several generations, and now they complement each other perfectly

    Reply
  • spamkiller007 November 28, 2019

    OK, first of all what is the problem with this game and MS store? It NEVER shows the game has an update and I'm still with version 27xxxx and can now launch and play it but nothing about an update. Miss the days when You could just download the update and do it manually. Microsoft has gone to shit last few years...

    Reply
  • mafj1979 November 17, 2019

    got the new 28529 on my PC... next to the old 27xxx one at least can switch between those.
    The other PC will not update for some reason so is 27xxx still.
    LAN certainly does not work my 2 pcs do not see each others created game. Got the xbox networking reported as fine on both.
    on 27xxx at least i was getting 20minutes of LAN playtime before game crashed mysteriously.
    20 pounds cannot believe

    and btw needed to use chrome as with edge i was unable to load comments or create a post. How things could go so bad

    Reply

of 50 comments